【対象機種】
adviceXross
【エラーメッセージ】
Error No.851: ファイルがオープンできませんでした
【原因】
- シンボル情報登録後の、Resetコマンドやステップ実行やブレーク操作により、ソースファイルが表示できない場合に発生します。
- デバッグ情報が含まれないデバッグ情報ファイルを登録した場合も、Resetコマンドやステップ実行やブレーク操作により、ソースファイルを表示することができずに、本エラーが発生します。
- コマンドによるダウンロード等で外部ファイルを参照している場合は、パス指定の誤りにより外部ファイルを参照できない場合に発生します。
【解決策】
- デバッグ情報ファイルのソースパス情報と、実際のソースパス情報が異なる場合は、シンボル情報登録後にソースパスの設定を行ってください。
- シンボル一覧ウィンドウで該当するソースファイル情報が存在するかどうかをご確認ください。
- コマンドによる外部ファイルの参照時は、パス指定に誤りが無いかをご確認ください。
【関連項目】