適用先: ULINK USB-JTAG Debugger
回答
このナレッジ記事に含まれている情報の適用先:
- ULINKpro のインストール
現象
WindowsXP 環境で ULINKpro アダプタのインストール時に、インストーラがエラーメッセージを表示します。
この現象が発生するのは、特定の PC だけのようです。どうしたら解決できますか?
原因
このエラーは、ULINKpro アダプタを PC にインストールしたときに、前回のログオフで Windows ユーザ セッションが適切に終了していなかった場合に発生することがあります。一部のシステム プロセスでは、レジストリ キー リンクが保持されている可能性があり、その結果、このインストール エラーが発生します。
解決策
この問題を解決するには、次のステップを実行します。
- Microsoft 社提供の UPHClean ユーティリティをダウンロードしてインストールします。
- Windows のデバイス マネージャ([マイ コンピュータ] を右クリックし、[プロパティ] をクリックします。 [ハードウェア] タブをクリックし、[デバイス マネージャ] ボタンをクリックします)を開きます。 [USB (Universal Serial Bus) コントローラ] で、Keil ULINK Pro デバイスを選択してアンインストールします。
- PC から ULINKpro アダプタを取り外します。
- PC を再起動して、通常の手順でログインします。
- ULINKpro アダプタを PC の USB ポートに再接続して、Windows による ULINKpro ドライバの適切な検出およびインストールを可能にします。
これで、エラーを伴わずに、インストールは通常どおりに完了します。引き続き、インストール時に問題が発生する場合は、Support までご連絡ください。