症状
ライセンスファイルをマージする以前は正常に動作していたにもかかわらず、ライセンスファイルをマージした後に想定した数のツールが同時に起動できない。
ケース1
同じバージョンのライセンスファイルを結合した場合
原因:
ライセンスファイルを結合する際にライセンス情報を破損した可能性が考えられます。
対処方法:
ライセンスサーバ上で下記のコマンドをコマンドプロンプトより入力し、認識されているライセンス数を確認してください。
> lmutil lmstat -a
エラー例:[3ライセンスをインストールしてあるが、一部のライセンスだけ認識されていない場合]
Users of rvd_arm: (Total of 3 licenses issued; Total of 0 licenses in use) Users of armlink: (Total of 2 licenses issued; Total of 0 licenses in use) Users of armsd: (Error: 1 licenses, unsupported by licensed server) Users of axd: (Total of 3 licenses issued; Total of 0 licenses in use)
上記の太文字ように、armlink のライセンスが"2"しか認識されておらず、"armsd"の行にエラー があると報告されている場合、
INCREMENT armlink ----... INCREMENT armsd ----....
で始まる行にライセンス情報の破損などのエラーがある可能性がございます。
ライセンスのカウント方法については下記FAQをご覧ください。
”FLEXlmサーバソフトウェアは、どのようにライセンスをカウントしますか”
下記FAQの中の、<2.ライセンスファイルをひとつにする>をご参考になり、ライセンスファイルのマージ作業を再度行ってください。
”他社製品に対して既に FLEXlm を使用しているサーバに、ArmのFlexフローティングライセンスを追加する方法を教えてください”
ライセンスファイルを修正しましたら下記FAQを参考になり、ライセンスサーバを再起動してください。
”FLEXlmサーバソフトウェアを実行するにはどうしたらいいですか”
ケース2
ADSなど最新でないバージョンのライセンスファイルに、新しいバージョンのライセンスを追加したら、想定された数のライセンスを認識しない。
原因:
以前のバージョンのツールで使用されていた古いバージョンのFLEXlmは、新しいバージョンのツールのライセンスファイルを認識できないことがあります。
対処方法:
この場合、FLEXlmサーバソフトウェアをバージョンアップすることで、新しいバージョンのライセンスを認識することができるようになります。 下記FAQをご参考ください。
”ライセンスサーバに新しいバージョンのライセンスファイルをインストールしたところ、ライセンスエラーが出るようになりました。 ”